Serwis wykorzystuje pliki cookies. Korzystając z forum wyrażasz zgodę na używanie cookies. Więcej informacji w regulaminie.
StacjePogody.waw.pl

Autor Wątek: Cumulus nie widzi stacji WS0101  (Przeczytany 8442 razy)

Offline pernaczy

  • Stratus
  • ***
  • Wiadomości: 188
  • Otrzymał podziękowań: 17
  • Płeć: Mężczyzna
    • NIESIOŁOWICE NA KASZUBACH-pogoda online
  • Miejscowość: Niesiołowice (Niesołejce)
  • Typ stacji: WH 2080, TFA Spring, Oregon AWS888N
Cumulus nie widzi stacji WS0101
« dnia: 20 Luty, 2013, 08:35:05 »
Dzisiaj w nocy Cumulus stracił kontakt ze stacją i do tej pory nie czyta danych. Po zamknięciu i ponownym odpaleniu program nie pobiera danych, świeci się dioda ERROR a w "error log" jest komunikat:
2013-02-20 08:23:12 : The station is not initialised
2013-02-20 08:23:12 : Byte 0 = 0A  Byte 1 = 20
2013-02-20 08:23:12 : Try resetting the console

Podpiąłem stację do drugiego kompa gdzie mam "starego Cumulusa" i Easy Weather. Cumulus też nie czyta stacji natomiast Easy Weather nie ma problemów. Widzi stację i czyta dane.
Czy ktoś ma pomysł co z tym "fantem" zrobić?
Piotr



Dzień w którym się czegoś nauczyłem nie jest dniem straconym.

Forum Użytkowników Stacji Pogodowych

Cumulus nie widzi stacji WS0101
« dnia: 20 Luty, 2013, 08:35:05 »

Offline Mark

  • Nimbostratus
  • ****
  • Wiadomości: 278
  • Otrzymał podziękowań: 13
  • Płeć: Mężczyzna
    • Pogoda w gminie Ślesin
  • Miejscowość: Ślesin k. Konina
  • Typ stacji: Conrad WS-0101 (WH 2080)
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #1 dnia: 20 Luty, 2013, 10:02:12 »
Ech. To jest ten problem z WH2080, który mi zdarza się niestety regularnie. Stacja sczytuje dane, ale coś wiesza się na połączeniu przez USB z komputerem. Pisałem o tym kiedyś  i pytałem się Steve'a na forum Cumulus, ale sam nie wie o co chodzi. Z bólem, ale w takich sytuacjach musiałem wyjmować baterie ze stacji i od nowa ją podłączać. Luka w danych niestety się tworzyła.
Zdarzało się to na moim laptopie, i teraz na razie raz na terminalu. Włączyłem na nim codzienne restartowanie Windowsa o 4. nad ranem i na razie dane płyną bez przerwy.

Offline pernaczy

  • Stratus
  • ***
  • Wiadomości: 188
  • Otrzymał podziękowań: 17
  • Płeć: Mężczyzna
    • NIESIOŁOWICE NA KASZUBACH-pogoda online
  • Miejscowość: Niesiołowice (Niesołejce)
  • Typ stacji: WH 2080, TFA Spring, Oregon AWS888N
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #2 dnia: 20 Luty, 2013, 11:50:07 »
Dzięki za odpowiedź. Trochę się pośpieszyłem z tym wątkiem bo rozwiązanie znalazłem na "WIKI" (tak to jest jak człowiek szybciej robi jak myśli": http://wiki.sandaysoft.com/a/FAQ#When_I_start_Cumulus.2C_I_get_the_error_message_.22The_station_is_not_initialised.22
Niestety jedynym wyjściem jest reset stacji.
Piotr
Piotr



Dzień w którym się czegoś nauczyłem nie jest dniem straconym.

Offline pernaczy

  • Stratus
  • ***
  • Wiadomości: 188
  • Otrzymał podziękowań: 17
  • Płeć: Mężczyzna
    • NIESIOŁOWICE NA KASZUBACH-pogoda online
  • Miejscowość: Niesiołowice (Niesołejce)
  • Typ stacji: WH 2080, TFA Spring, Oregon AWS888N
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #3 dnia: 24 Luty, 2013, 18:48:43 »
22 lutego miałem kolejny "zwis" ale innego typu. Nie było komunikatu "The station is not initialised" tylko po prostu komunikat o braku połączenia ze stacją i o konieczności resetu stacji. Zrobiłem ten reset i życie wróciło do normy (ale ile razy można resetować). Poszukałem na forum Sandaysoft i znalazłem wątek poświęcony problemowi "wieszania się USB" (ALE NIE Z POWODU KOMUNIKATU "Station is not initialised" bo w takim przypadku "zalecają" tylko reset): http://sandaysoft.com/forum/viewtopic.php?f=13&t=7150 . Dwa z wariantów rozwiązania problemu są przedstawione w poście nr 5.

1. Niektóre komputery (zwłaszcza laptopy) mogą dawać za słabe zasilanie dla portów USB. Trzeba zastosować "huby USB" z zewnętrznym zasilaniem (myślę, że ten wariant 
    można zastosować jak wariant nr 2 nie zadziała). 
2. Generalnie chodzi o to, że Windows w ramach oszczędzania energii może wyłączać zasilanie tych portów USB, które system traktuje jako "nieczynne". Na wszelki
    wypadek trzeba w "Menedżerze urządzeń" odszukać wszystkie "huby USB" (patrz załącznik), kliknąć na każdy prawym klawiszem, wybrać "właściwości/zarządzanie
    energią" i usunąć zaznaczenie dla opcji "zezwalaj komputerowi na wyłączanie tego urządzenia w celu oszczędzania energii".
Zastosowałem wariant drugi i czekam. Na razie chodzi.
Piotr

Piotr



Dzień w którym się czegoś nauczyłem nie jest dniem straconym.

Offline Mark

  • Nimbostratus
  • ****
  • Wiadomości: 278
  • Otrzymał podziękowań: 13
  • Płeć: Mężczyzna
    • Pogoda w gminie Ślesin
  • Miejscowość: Ślesin k. Konina
  • Typ stacji: Conrad WS-0101 (WH 2080)
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #4 dnia: 24 Luty, 2013, 21:37:59 »
Tę opcję z nr 2 ustawiłem w swoim terminalu, gdzie jest Windows XP, bo po paru godzina port USB był odłączany i stacja nie przesyłała danych. Pomimo to raz też zdarzyła mi sie tu taka zawiecha, tylko nie pamiętam jaki był wtedy komunikat. Na moim laptopie zdarzało się to dużo częściej. A teraz jak pisałem wyżej jak ustawiłem automatyczny ponowny rozruch systemu (restart) to na razie nie ma tego komunikatu.
Ostatnio w piątek myślałem, że znów do tego doszło, a to prądu w domu nie było 3 h ;)

Offline Kantrzyn

  • Cirrus
  • *
  • Wiadomości: 14
  • Otrzymał podziękowań: 2
  • Typ stacji: WH2080
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #5 dnia: 16 Wrzesień, 2014, 15:12:17 »
Też miałem ten problem kilka razy i rozwiązywałem go przez reset stacji poprzez wyjęcie baterii. Najgorsze, że stacja po ponownym uruchomieniu "finksowała" i zmyślała jakieś niebotyczne opady (tylko na chwile po włączeniu). I zdarzyło mi się, że te bzdury poszły na Wundergrounda.

Dzisiaj zastosowałem się do rad ze strony wiki i zadziałało (zaktualizowałem program i wstawiłem tą dodatkową komendę do pliku cumulus.ini). Także nie straciłem żadnych danych a Cumulus ładnie sczytał zaległe dane.  Poza tym z tego co zauważyłem, to ten problem wyskakiwał zawsze po zapisaniu całej pamięci w stacji i jej nadpisywaniu. Także rozwiązaniem może być również regularne czyszczenie pamięci w stacji. Chociaż nie daje gwarancji, bo może był to tylko zbieg okoliczności.

 For Fine Offset stations, when Cumulus starts up, it checks the first two bytes of the station's memory. They are supposed to contain the values Hex 55 and Hex AA to indicate that the station has initialised itself correctly. If they do not, then presumably the station has had some kind of internal problem, so Cumulus doesn't try to read any data from it. A reset of the station normally fixes this - remove the batteries and the USB cable; but note that you will almost certainly lose any stored data in the logger.
If you want to force Cumulus to ignore this check (not recommended), edit cumulus.ini and add a line to the [Station] section: EWdisablecheckinit=1
You will most likely not have any success with this, as your station memory is probably corrupted anyway.
Note that for this setting to work, you need to be using version 1.9.3, build 1034 or later.

Offline Brecht

  • Cirrocumulus
  • **
  • Wiadomości: 73
  • Otrzymał podziękowań: 3
  • Typ stacji: Oregon Scientific BAR208HG; Conrad Ws-0101
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #6 dnia: 09 Styczeń, 2015, 14:00:38 »
Panowie, sorry, że odkopuję temat, ale podpiąłem niedawno swoją stację do terminala i wysyłam dane z Cumulusa do Weatherunderground. Dwukrotnie w ciągu dwóch miesięcy spotkałem się z tym problemem. U mnie komunikat Cumulusa jest następujący:
 "Fine Offset station not responding. You may need to reset it (remove batteries and USB cable)". Również szukałem rozwiązania w sieci, jednak chyba sam wpadłem na rozwiązanie. Po kolejnym zwisie z ciekawości podpiąłem stację do laptopa i odpaliłem EasyWeather, jednak również ten program nie mógł uzyskać połączenia z WS0101. Wnioskuję, że winna jest tu sama stacja, najprawdopodobniej chodzi o regularne czyszczenie "pamięci". Odkąd stacja podpięta jest pod Cumulusa nie czyszczę tej pamięci tak jak w EasyWeather. Przypuszczam, że po pewnym okresie nadpisywania danych w pamięci stacji dochodzi do tego typu zwisu. Zacząłem czyścić pamięć co jakiś czas przyciskami na konsoli i na razie problem z głowy.

Offline Brecht

  • Cirrocumulus
  • **
  • Wiadomości: 73
  • Otrzymał podziękowań: 3
  • Typ stacji: Oregon Scientific BAR208HG; Conrad Ws-0101
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #7 dnia: 16 Styczeń, 2015, 15:46:08 »
Zonk - transmisja danych od stacji do terminala zwiesiła się przy nie zapełnionej do końca pamięci. Testuję dalej - tym razem wyczyściłem pamięć przy pomocy Easy Weather, ponieważ ostatni reset danych odbył się tylko poprzez wyjecie baterii... Obserwacje trwają.

Offline pernaczy

  • Stratus
  • ***
  • Wiadomości: 188
  • Otrzymał podziękowań: 17
  • Płeć: Mężczyzna
    • NIESIOŁOWICE NA KASZUBACH-pogoda online
  • Miejscowość: Niesiołowice (Niesołejce)
  • Typ stacji: WH 2080, TFA Spring, Oregon AWS888N
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #8 dnia: 16 Styczeń, 2015, 16:31:17 »
WS0101 ma wbudowaną procedurę kasowania pamięci i resetu stacji (patrz załącznik).
Pozdrawiam,
Piotr
Piotr



Dzień w którym się czegoś nauczyłem nie jest dniem straconym.

Offline Mincek

  • Cirrus
  • *
  • Wiadomości: 22
  • Otrzymał podziękowań: 0
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #9 dnia: 17 Październik, 2016, 09:40:41 »
Odświeżam trochę temat gdyż od 2 dni mam problem ze stacją.  Otóż działa sobie działa, potem ujmijmy ze cumulus się "wiesza" i jest komunikat że powinienem zrestartować stacje poprzez wyjęcie baterii lub odłączeniu kabla usb.  W moim wypadku wystarczy restart samego oprogramowania czyli cumulus`a i wszystko wraca do normy.

Poczytałem trochę i dziś byłem przy stacji i zauważyłem że pamięć jest w 100% zapełniona, ale przecież stacja powinna sobie nadpisywać. Co jeśli to będzie problemem ?? jeśli skasuję wszystkie dane ze stacji, to w internecie także nie będzie żadnej już historii ?? jak to wygląda kasowanie tych danych ??

Offline pernaczy

  • Stratus
  • ***
  • Wiadomości: 188
  • Otrzymał podziękowań: 17
  • Płeć: Mężczyzna
    • NIESIOŁOWICE NA KASZUBACH-pogoda online
  • Miejscowość: Niesiołowice (Niesołejce)
  • Typ stacji: WH 2080, TFA Spring, Oregon AWS888N
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #10 dnia: 17 Październik, 2016, 12:43:08 »
W internecie nic nie ginie. Do internetu wysyła Cumulus a nie stacja. Przy każdym uruchomieniu Cumulus czyta "zaległe" dane ze stacji zaczynając od momentu kiedy zapisał sobie ostatnie dane przed wyłączeniem. Tak więc wyzerowanie danych ze stacji nie usuwa niczego co już Cumulus zdążył pobrać.
Stacja rzeczywiście nadpisuje nowe rekordy na najstarsze jeśli pamięć jest całkowicie zapełniona.

Proponuję przy następnym "zwieszeniu się" Cumulusa "spakować folder "diags" i wysłać stosowne zapytanie do twórcy Cumulusa na stronie: http://sandaysoft.com/forum/viewforum.php?f=13 (założyć nowy wątek i opisać problem) załączając zarchiwizowany katalog "diags". Forum jest niestety angielskojęzyczne.
Steve (twórca Cumulusa) zazwyczaj bardzo szybko analizuje takie przypadki i udziela stosownych rad. Aktualnie trzeba się liczyć z opóźnieniem bo jakiś czas temu Steve "wybrał wolność" czyli zmienił tryb życia na wędrowny (na stałe zamieszkał w kamperze i podróżuje po kraju) więc na forum udziela się rzadziej. Przed wysłaniem widomości na forum dobrze byłoby przeszukać formu (pod podanym linkiem) czy podobne problemy nie były już zgłaszane.
Piotr
Piotr



Dzień w którym się czegoś nauczyłem nie jest dniem straconym.

Offline Mincek

  • Cirrus
  • *
  • Wiadomości: 22
  • Otrzymał podziękowań: 0
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #11 dnia: 17 Październik, 2016, 13:02:55 »
Sprawdzę i postaram się ew. odezwać tam na forum.

Ja mam nadzieję że to był tylko jednak poluzowany kabel USB (choć dlaczego wtedy tylko reset programu pomagał ??)

Nie bardzo tylko rozumiem sczytywania przez cumulusa danych bo nie do końca mi to pasuje.

Przykład np. tylko na temperaturze wewnętrznej, mamy godzinę 23 jest temperatura 23 stopnie ( w tym momencie cumulus się zwiesza) do godz. 5 rano (do momentu resetu programu) jest pozioma kreska, od restartu wykres się zmienia czyli są wahania temperatur.

Zgodnie z tym co mówisz, cumulus po restarcie powinien sobie sczytać poprzednie dane, które były błędne..

Offline Mincek

  • Cirrus
  • *
  • Wiadomości: 22
  • Otrzymał podziękowań: 0
Odp: Cumulus nie widzi stacji WS0101
« Odpowiedź #12 dnia: 08 Listopad, 2016, 09:08:32 »
Ponownie pojawia mi się problem wieszania stacji.  Dziś zmieniłem opcje zasilania na USB zobaczymy czy to pomoże.

A co jeszcze z "Dzisiaj zastosowałem się do rad ze strony wiki i zadziałało (zaktualizowałem program i wstawiłem tą dodatkową komendę do pliku cumulus.ini)" o jaka zmianę chodzi w cumulus.ini ??