Serwis wykorzystuje pliki cookies. Korzystając z forum wyrażasz zgodę na używanie cookies. Więcej informacji w regulaminie.
StacjePogody.waw.pl

Autor Wątek: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)  (Przeczytany 1144 razy)

Offline adamm

  • Cirrus
  • *
  • Wiadomości: 14
  • Otrzymał podziękowań: 0
WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« dnia: 30 Październik, 2015, 21:03:31 »
Stacja zakupiona 22.10.2012 od paru dni nie odświeżają się dane z czujników ,komunikacja z nimi jest po wywołaniu ręcznym tylko jeden raz na początku . Zmienione baterie zresetowane i dalej nic ,ponieważ jest to urządzenie programowane można podejrzewać że na tyle zostało zaprogramowane albo podejrzenia moje są zbyt pochopne .
I tu pytanie czy może ktoś polecić stacje z usb deszczem wiatrem która by działała dłużej w rozsądnej cenie ?

Forum Użytkowników Stacji Pogodowych

WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« dnia: 30 Październik, 2015, 21:03:31 »

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 466
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • ikonka GG
    • MeteoSerwis24
  • Miejscowość: Świdnik Duży Drugi
  • Typ stacji: WS3600 - 11
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #1 dnia: 31 Październik, 2015, 00:03:53 »
A co w przypadku jak znajdują się blisko siebie, np. 1m od siebie w tym samym pomieszczeniu w domu? Też nie ma danych przesyłanych?

Offline adamm

  • Cirrus
  • *
  • Wiadomości: 14
  • Otrzymał podziękowań: 0
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #2 dnia: 31 Październik, 2015, 12:29:07 »
Dane odświeżają się jedynie przy ręcznym przyciśnięciu przycisku jeden raz nie ma znaczenia odległość (przecież to nie volkswagen)

Offline Sullivan

  • Cirrocumulus
  • **
  • Wiadomości: 40
  • Otrzymał podziękowań: 4
  • Płeć: Mężczyzna
    • ikonka GG
  • Miejscowość: Krosno Odrzańskie
  • Typ stacji: WS-0101
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #3 dnia: 08 Listopad, 2015, 08:28:04 »
Zobacz czy co 48 sekund w stacji bazowej pokazuje się ikona próby pobrania danych z czujnika, a w czujniku zewnętrznym czy co 48 sekund mruga dioda sygnalizująca wysłanie danych do bazy. Może zrobił się problem z synchronizacją bazy z czujnikiem zewnętrznym.

Offline adamm

  • Cirrus
  • *
  • Wiadomości: 14
  • Otrzymał podziękowań: 0
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #4 dnia: 09 Listopad, 2015, 11:11:52 »
Z zewnątrz dane są wysyłane co 48 sekund ale baza ich nie odbiera, nie ma żadnej sygnalizacji odbioru nigdy oprócz ręcznego wywołania , czeka wtedy na sygnał zewnętrzny odbierze i dalej cisza. Wynika z tego że komunikacja między nadajnikiem i odbiornikiem jest tylko nie ma próby odczytu co kolejne 48 sekund nigdy później nie odczytuje.   

Offline Sullivan

  • Cirrocumulus
  • **
  • Wiadomości: 40
  • Otrzymał podziękowań: 4
  • Płeć: Mężczyzna
    • ikonka GG
  • Miejscowość: Krosno Odrzańskie
  • Typ stacji: WS-0101
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #5 dnia: 10 Listopad, 2015, 15:56:25 »
Więc wygląda to w takim razie na uszkodzenie którejś nóżki procesora, która odpowiada za wysłanie impulsu do układu nadawczo - odbiorczego, który po 48 sekundach odbiera dane z czujnika zewnętrznego, lub uszkodzone oprogramowanie ( shit happens ;/). Poważna awaria. Kwestia tylko tego czy jest to fizyczne uszkodzenie czy coś się stało z softem. Z tego co napisałeś jasno wynika, że baza nie synchronizuje się automatycznie z czujnikiem skoro po 48 sekundach nie pokazuje się ikona odbioru danych. Układ nadawczo - odbiorczy w bazie jest na pewno sprawny skoro po ręcznej próbie ściągnięcia dane pokazują się w bazie. Nie musisz koniecznie szukać nowej stacji skoro to problem z bazą. W sklepie thermocenter zapewne kupiłbyś samą bazę do tej stacji ale decyzja należy do Ciebie.   

Offline adamm

  • Cirrus
  • *
  • Wiadomości: 14
  • Otrzymał podziękowań: 0
Odp: WH2080 - Brak kontaktu z czujnikami (odświeżanie danych)
« Odpowiedź #6 dnia: 11 Listopad, 2015, 14:54:17 »
Nie jest to uszkodzenie fizyczne,
Cytuj
czy coś się stało z softem
podejrzewam że dodano o jeden "if" za dużo (tylko podejrzenia).
Fajnie by było jakby gogle coś powiedziało o (modulacja ASK ,pasmo 868 symbol MA1U lub V01 raczej V) ,ASK868MA1V01 -odbiornik.
Raczej skłaniam się do zakupu większego wyświetlacza i jakiegoś zestawu radiowego.
Same czujniki są opisane http://botland.com.pl/czujniki-pogodowe/3630-stacja-pogodowa-z-pomiarem-kierunku-i-predkosci-wiatru.html
a i mały prototyp działa temperatura wilgotność ciśnienie https://www.youtube.com/watch?v=P1IKmM5hwco