Serwis wykorzystuje pliki cookies. Korzystajc z forum wyraasz zgod na uywanie cookies. Wicej informacji w regulaminie.
StacjePogody.waw.pl

Autor Wątek: WS 3600 - 11 brak komunikacji z PC  (Przeczytany 3982 razy)

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 481
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • MeteoSerwis24
WS 3600 - 11 brak komunikacji z PC
« dnia: 20 Kwiecień, 2011, 15:34:30 »
Posiadam stację WS 3600 11 lecz gdy podłączam ją do komputera do portu COM wyskakuje informacja w programie Heavy Weather Pro 3600 że nic nie ma podłączone do portu COM. W czym tkwi problem czy rzeczywiście wtyk ma mieć 4 przewody od portu COM bo gniazdo ma 6? Co zrobić aby wreszcie podłączyć WS 3600 do PC?

Forum Użytkowników Stacji Pogodowych

WS 3600 - 11 brak komunikacji z PC
« dnia: 20 Kwiecień, 2011, 15:34:30 »

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 481
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • MeteoSerwis24
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #1 dnia: 23 Kwiecień, 2011, 22:33:06 »
Nie wiem jak się scala posty więc tutaj dopisuję:
Znalazłem taki schemat połączeń lecz nie wiem czy zadziała:

RJ12 --- DB9 --- Pin Name
1 ------- 5 ------ GND
2 ------- 3 ------ TXD
3 ------- 4 ------ DTR
4 ------- 7 ------ RTS
5 ------- 6 ------ DSR
6 ------- 8 ------ CTS

Dodam że u mnie w przewodzie (wtyk rj 11) są następujące połączenia:
pin 1 - brak pinu 1
pin 2 do pinu 4 DB9
pin 3 do pinu 3 DB9
pin 4 do pinu 2 DB9
pin 5 do pinu 7 DB9
pin 6 - brak pinu 6
Czy to ma tak być?

Offline Parasol

  • Administrator
  • *****
  • Wiadomości: 2376
  • Otrzymał podziękowań: 114
  • Płeć: Mężczyzna
    • Smartfonki.pl
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #2 dnia: 24 Kwiecień, 2011, 09:21:50 »
Zapraszam do dodawania opinii o swojej stacji pogodowej na stronie:  https://stacje-pogody.pl - Twoja opinia pomoże dokonać właściwego wyboru innym!

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 481
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • MeteoSerwis24
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #3 dnia: 24 Kwiecień, 2011, 11:15:22 »
Niestety tam nie ma informacji o przewodzie a jedynie ten sam problem. Ponadto okazuje się że deszczomierz nic nie pokazuje :( chociaż deszcz u mnie pada już z 30 minut, nawet jak odłączę czujnik to wyświetlane są same 0 czy to normalne. Zakupiłem przewód 6 żyłowy i zobacze czy się skomunikuje z PC.

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 481
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • MeteoSerwis24
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #4 dnia: 27 Kwiecień, 2011, 12:47:27 »
Niestety 6- cio żyłowy tez nie działa pisze No weather station at port Com 1, 2,3,4,5,6,7,8 .Co Zrobić czy w ogóle ta stacja się skomunikuje z PC?

Offline Parasol

  • Administrator
  • *****
  • Wiadomości: 2376
  • Otrzymał podziękowań: 114
  • Płeć: Mężczyzna
    • Smartfonki.pl
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #5 dnia: 27 Kwiecień, 2011, 12:53:18 »
Niestety 6- cio żyłowy tez nie działa pisze No weather station at port Com 1, 2,3,4,5,6,7,8 .Co Zrobić czy w ogóle ta stacja się skomunikuje z PC?

A masz podłączone pod COM czy przez przejściówkę do USB?

Sprawdź COM w komputerze czy jest na 100% ok, spróbuj podłączyć stacje do innego PC.
Zapraszam do dodawania opinii o swojej stacji pogodowej na stronie:  https://stacje-pogody.pl - Twoja opinia pomoże dokonać właściwego wyboru innym!

Offline mati211p

  • Nimbostratus
  • ****
  • Wiadomości: 481
  • Otrzymał podziękowań: 15
  • Płeć: Mężczyzna
    • MeteoSerwis24
Odp: WS 3600 - 11 brak komunikacji z PC
« Odpowiedź #6 dnia: 27 Kwiecień, 2011, 15:25:47 »
Przyjrzałem się jeszcze raz i najpierw pomyliłem 1 z 6 w Rj 12 dlatego wszystko było na odwrót a potem pomyliłem 6 z 9 w DB9 jak robiłem bo do góry nogami na wtyku z drugiej strony było napisane i oczywiście konsekwencją wpierw połączenia były;

RJ12 --- DB9 --- Pin Name
6 ------- 5 ------ GND
5 ------- 3 ------ TXD
4 ------- 4 ------ DTR
3 ------- 7 ------ RTS
2 ------- 6 ------ DSR
1 ------- 8 ------ CTS
Póżniej :

RJ12 --- DB9 --- Pin Name
1 ------- 5 ------ GND
2 ------- 3 ------ TXD
3 ------- 4 ------ DTR
5 ------- 7 ------ RTS
4 ------- 9 ------ RI
6 ------- 8 ------ CTS
a teraz jest juz ok i działa dzięki wszystkim za pomoc. Poprawne połaczenie to:
 
RJ12 --- DB9 --- Pin Name
1 ------- 5 ------ GND
2 ------- 3 ------ TXD
3 ------- 4 ------ DTR
4 ------- 7 ------ RTS
5 ------- 6 ------ DSR
6 ------- 8 ------ CTS i tak działa na 100%
Poniżej zamieszczam pinologię RJ12 bo ja się pomyliłem:)