Serwis wykorzystuje pliki cookies. Korzystając z forum wyrażasz zgodę na używanie cookies. Więcej informacji w regulaminie.
StacjePogody.waw.pl

Autor Wątek: Cumulus MX na raspberry Pi 2  (Przeczytany 14915 razy)

Offline beskidus

  • Cirrus
  • *
  • Wiadomości: 2
  • Otrzymał podziękowań: 0
    • Stacja pogody Milówka
  • Miejscowość: Milówka, Beskid Żywiecki
  • Typ stacji: Conrad WS 0101
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #45 dnia: 25 Lipiec, 2018, 10:57:44 »
Witam,
Żadnym fachowcem nie jestem, sam długo borykałem się z instalacją mono, metodą prób i błędów, ale w końcu wyszło.
Spróbuj najpierw odinstalować mono tymi komendami po kolei:

       sudo apt-get remove mono-complete

      sudo apt-get purge mono-complete

      sudo apt-get autoremove

Potem wklep taką komendę:

  echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.2.8 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

  Następnie taką:

sudo apt-get install mono-complete

I sprawdź wersję:

mono --version

Mam nadzieję, że pójdzie.

« Ostatnia zmiana: 25 Lipiec, 2018, 17:50:53 wysłana przez beskidus »

Forum Użytkowników Stacji Pogodowych

Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #45 dnia: 25 Lipiec, 2018, 10:57:44 »

Offline andybyd

  • Cirrus
  • *
  • Wiadomości: 4
  • Otrzymał podziękowań: 0
  • Typ stacji: WS 1080
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #46 dnia: 25 Lipiec, 2018, 19:07:35 »
Witam.
Dzięki za błyskawiczną reakcję. Wykonałem dokładnie wszystkie polecenia (odinstalowałem mono, wybrałem wcześniejszą wersję, którą zainstalowałem). Już w czasie instalacji spostrzegłem w przesuwających się wierszach 4.6.2.7... Komenda mono --version zwróciła 4.6.2. Przy próbie uruchomienia Cumulusa otrzymałem taki sam listing jak poprzednio. Ciekawe dlaczego zainstalowała się nowa wersja Mono?
Pogrążony w smutku
Andrzej.

Offline beskidus

  • Cirrus
  • *
  • Wiadomości: 2
  • Otrzymał podziękowań: 0
    • Stacja pogody Milówka
  • Miejscowość: Milówka, Beskid Żywiecki
  • Typ stacji: Conrad WS 0101
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #47 dnia: 25 Lipiec, 2018, 19:43:26 »
Tak na szybko: mam starszą wersję raspbiana, może powinieneś  też zainstalować starszą? I potem dopiero próbować z mono?

Offline andybyd

  • Cirrus
  • *
  • Wiadomości: 4
  • Otrzymał podziękowań: 0
  • Typ stacji: WS 1080
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #48 dnia: 25 Lipiec, 2018, 20:17:07 »
Póki co muszę zostawić malinkę ze względu na wyjazd, ale po powrocie zajmę się raspbianem. Dzięki.

Offline chinczyk

  • Cirrus
  • *
  • Wiadomości: 11
  • Otrzymał podziękowań: 0
  • Płeć: Mężczyzna
  • Ciekawość to pierwszy stopień do pozyskania wiedzy
    • ikonka GG
    • Stacja pogodowa PiWS
  • Miejscowość: Jelenia Góra
  • Typ stacji: Rasberry Pi WS + WS0101
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #49 dnia: 25 Lipiec, 2018, 22:36:22 »
Witajcie ja zainstalowałem 2 tygodnie temu najnowszą wersję raspbiana nie robiłem apt-get upgrade i zmieniłem w /etc/apt/source.list repo na starsze i zainstlowało mi poprawne mono i stacja śmiga . Może to też rozwiązanie dla kolegi

Offline andybyd

  • Cirrus
  • *
  • Wiadomości: 4
  • Otrzymał podziękowań: 0
  • Typ stacji: WS 1080
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #50 dnia: 13 Sierpień, 2018, 20:19:46 »
Witam. Siedzę już kolejny dzień z malinką i z tym postem przed oczami i staram się coś wykombinowac. Nie ukrywam, że linux jest dla mnie czymś nowym i tajemniczym. Póki co chyba trafnie odkryłem, że w ścieżce dostępu do repo brakowało troszkę i uzupełniłem to. Ale cóż z tego kiedy dostaję taką odpowiedź jak w załączniku, która nic mi nie mówi. Proszę o jakąś poradę.

Offline chinczyk

  • Cirrus
  • *
  • Wiadomości: 11
  • Otrzymał podziękowań: 0
  • Płeć: Mężczyzna
  • Ciekawość to pierwszy stopień do pozyskania wiedzy
    • ikonka GG
    • Stacja pogodowa PiWS
  • Miejscowość: Jelenia Góra
  • Typ stacji: Rasberry Pi WS + WS0101
Odp: Cumulus MX na raspberry Pi 2
« Odpowiedź #51 dnia: 14 Sierpień, 2018, 23:58:11 »
Hmm nie staraj się zainstalować MONO z starego repo . Okłam cały system aby uzyskać stare MONO. Jak zmieniłem główne repo w /etc/apt/source.list na starą wersję systemu zrobiłem apt-get update i nie robiłem upgrade , dałem apt-get install mono (chyba coś było więcej mono-*) i poszło może to Ci pomoże